Delay in email delivery for EU environment

Incident Report for Speakap

Resolved

This incident has been resolved.
Posted Apr 29, 2024 - 19:08 CEST

Identified

There is a delay in the delivery of transactional email, affecting customers hosted in the EU. We are working to resolve this as soon as possible.
Posted Apr 29, 2024 - 11:24 CEST
This incident affected: Data Center (Amsterdam).