Degraded performance on EU environment

Incident Report for Speakap

Resolved

This incident has been resolved.
Posted Sep 20, 2022 - 09:35 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2022 - 09:22 CEST

Investigating

We are currently investigating this issue.
Posted Sep 20, 2022 - 09:05 CEST
This incident affected: Data Center (Amsterdam).