Delay in receiving emails
Incident Report for Speakap
Resolved
March 18th / 8:45 AM - GMT+1
Microsoft confirms Email delivery issues MSFT domains to be solved.
Posted Mar 18, 2020 - 09:15 CET
Monitoring
Global Escalations Desk of Microsoft identified they still had a restriction, limiting total volume. The restriction was removed around 11:30 PM GMT+1 - March 17th
Posted Mar 18, 2020 - 09:12 CET
Identified
Global Escalations Desk of Microsoft identified the problem reported the automatically generated restrictions to be resolved
Posted Mar 18, 2020 - 09:09 CET
Investigating
Delay receiving emails at Microsoft, particularly with domains: hotmail.com, outlook.com, hotmail.nl, live.nl and msn.com.
Microsoft is currently investigating the issue
Posted Mar 17, 2020 - 22:32 CET