Degraded performance
Incident Report for Speakap
Resolved
This incident has been resolved.
Posted Mar 15, 2020 - 23:11 CET
Monitoring
Performance has stabilized. We are continuing to monitor the platform.
Posted Mar 15, 2020 - 22:31 CET
Update
We are working to resolve the performance issues.
Posted Mar 15, 2020 - 21:40 CET
Investigating
We are currently investigating slow response times experienced by our customers.
Posted Mar 15, 2020 - 18:48 CET
This incident affected: Data Center (Amsterdam).